Post New Topic & Search Forum boxes MISSING in Safari

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :froth: :loopy: :| :mrgreen: :demonic: 0:) 0;) :argue: :wry:
View more smilies
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Post New Topic & Search Forum boxes MISSING in Safari

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by andrewbeasley » Tue Nov 29, 2016 2:49 pm

Do not mix JavaScript up with the full blown bug ridden Java from Oracle - though similar the risks are different have a look at https://nakedsecurity.sophos.com/2013/0 ... r-friends/ for more info - Sophus recommend you leave JavaScript on. Wait till HTML 5 starts introducing its own security issues :-)

I thought Firefox came with JavaScript off by default - been years since I used it (Safari and Chrome for me)?

Styles are a board function and found under User Control Panel, drop down Overview till you see board preferences then the style is a drop down though why only two are here I do not know. Maybe it's time for a board upgrade?

Anyway glad you are working again.

Andrew

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by PaintsByNumbers » Tue Nov 29, 2016 8:17 am

How do I find Styles?
no proxy
no extensions or plug ins
it was Javascript being disabled. That's bad web page design, java is a security hole.

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by andrewbeasley » Tue Nov 29, 2016 1:21 am

Not sure what tech support you will get from the admin here (ep as we are on a Mac) but I'll help to set the ball rolling but as Im in the middle of upgrading the last El Cap machine here I'll see what we can do without a test box to start with (may be able to get a VM up and running in a day or so).

What 'style' are you running? Can you set it to 'Air Red' if different please?

Please disable the Mac firewall and any AV you have
Please disable any proxy server - connect direct to the internet for this
Please disable all extensions and plug ins in Safari
Please enable Javascript in Safari
Close and restart Safari

Can you then go to viewforum.php?f=18 and make and post a screen print of what you see?

Andrew

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by PaintsByNumbers » Mon Nov 28, 2016 9:44 pm

El Capitan 10.11.6 & Safari, no boxes in Frother Feedback Box page. present with Firefox.

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by andrewbeasley » Mon Nov 28, 2016 5:03 pm

Just checked on the other machine and both boxes present - thats still down level (though downloading Sierra) on version 10.0.1 (11602.2.14.0.7) with both Ghostry and Adblock

The only way I can see the 'post topic' missing is at a higher level e.g. unread posts or at places such as the 'War Room' viewforum.php?f=53 from the main menu. Both of these span forum (fori / forums?) so I can understand the lack of a new post option as it would not know where to put it.

Re: Post New Topic & Search Forum boxes MISSING in Safari

Post by andrewbeasley » Mon Nov 28, 2016 4:26 pm

Both visible on my Safari - version though is 10.0.1 (12602.2.14.0.7) - I'm running Sierra with both Ghostry and Adblock though no Flash.

Post New Topic & Search Forum boxes MISSING in Safari

Post by PaintsByNumbers » Mon Nov 28, 2016 11:04 am

Empty space where those boxes go, in Safari Version 10.0.1 (11602.2.14.0.7)

FireFox works.

Top